gps-icesailing

win7, 8, 10 can't connect gw60.
tried several computers.

"Device changed, com ports rescaned!!!Check if the proper com port is selected...
Check if the GW60 COM USB mode is selected."

Sometimes it works, next time, not...
it's not the cable. i have two of them.

the golden connectorplates are fine.

any tips? gw60 failure?

Solved...
by reinstalling latest firmware.
Now it works fine.

Hi, I have the same issue. I got a GW60 replaced under warranty, I received a used watch with different serial number, so not my ''original'' watch. It seems to work, however, I can't connect it to my computer (windows 10). I reinstalled the firmware, update etc., basically tried everything I could think of.

The message I get is always the same. COM port error ( Device changed, Com ports rescaned, Device in MTN mode, Device changed, Device sync failed, device disconnected, USB device detected, Devise changed, com port rescaned and so on and so forth).

Installed the com port driver, cleaned the contacts, checked the pins, tried two different cables. What other options do I have? Any advice?

Thanks!

WINDSURFLAND